233 Benutzer online
16. November 2018, 02:26:39

Windows Community



Zum Thema Linux Mint + Windows. Nach ändern der Startoptionen startet Windows nicht mehr - Moin Ihrs!Folgendes:C Platte: 3 partitionen Partition 1: Windows 7 Ultimate 64bitPartition 2: Linux Mint 13 64 bitPartition 3: Swap AuslagerungBootlaoder ist Gr... im Bereich Windows 7 Forum
Autor Thema:

Linux Mint + Windows. Nach ändern der Startoptionen startet Windows nicht mehr

 (Antworten: 7, Gelesen 8320 mal)

  • Windows 1.0
  • Beiträge: 7
Linux Mint + Windows. Nach ändern der Startoptionen startet Windows nicht mehr
« am: 19. Oktober 2012, 13:39:31 »
Moin Ihrs!

Folgendes:

C Platte: 3 partitionen

Partition 1: Windows 7 Ultimate 64bit
Partition 2: Linux Mint 13 64 bit
Partition 3: Swap Auslagerung

Bootlaoder ist Grub.

Getsern habe ich unter Windows das nervige Origin per msconfig aus dem Systemstart genommen und danach noch eine Weile mit dem Rechner gearbeitet ohne direkt neu zu starten.

Heute morgen starte ich meinen Rechner und bis zur OS-Auswahl ist alles wie gehabt, nachdem ich Windows 7 zum booten ausgewählt habe kommt jedoch die Routine wie wenn man die Win-DVD einlegt (Daten werden geladen etc) dann kommt eine Fehlermeldung das Windows nicht gebootet werden konnte und ich per Win-DVD eine reperatur durchführen soll. Also Win-DVD rein und Rechner neu gestartet. Es wurde auch von DVD gebootet und man kommt in das Instal-Menü von Windows. Dort habe ich dann die Reperatur ausgewählt und er fängt an nach vorhandenen Windowsinstallationen zu suchen, allerdings findet er das installierte Windows nicht. bzw zeigt mir keins an. Reperatur kann ich trotzdem durchführen lassen und wenn ich mir die Diagnose der durchgeführten Reperatur anschaue zeigt er da auch einen Fehler an den er angeblich gefunden und beseitigt hat. Windows startet trotzdem nicht und das Spiel geht von vorne los. Nach 4 mal hatte ich keine Lust mehr.

Weiß jemand von Euch was das ist, bzw was ich dagegen tun kann?

Ich habe vor 6 oder 7 Tagen einen Wiederherstellungspunkt gesetzt als ich was am Rechner gemacht habe, allerdings findet er keinen und eben auch kein System... Linux startet ganz normal und ohne Mucken...

Ich weiß, ist alles nicht ganz genau 100% wiedergegeben wie es da bei den Meldungen stand, aber ich schreibe es grad aus dem Kopf, da ich zur Zeit bei der Arbeit bin und es mir gerade nicht noch einmal anschauen kann...

Hoffe Ihr könnt trotzdem etwas dazu sagen!?

MfG

(auto)bot

  • Team
  • Windows XP
  • Beiträge: 5501
  • Viva la Revolución
« Antwort #1 am: 19. Oktober 2012, 14:15:34 »
Da hste dir den MBR von Windows zerschossen. Und dadurch das Grub vorm MBR geladen wird, wirds mit wiederherstellen schwer.

Ich würde dir raten, das du neu installierst. Dann kannste dir auch mal die Möglichkeit anschauen, Linux in ner virtuellen Festplatte zu installieren. Das machts grad für Anfänger einfacher. Gerade wenn man sich Linux zerschiesst, kann man einfach nen Backup der virtuellen Festplatte unter Windows drüberkopieren

  • Windows 1.0
  • Beiträge: 7
« Antwort #2 am: 19. Oktober 2012, 15:09:14 »
Danke erstmal für die schnelle Antwort!

Also ich muss gestehen, das mir die Variante mit Linux auf einer Virtuellen Festplatte auf den ersten Blick nicht sonderlich zusagt. Habe jetzt seid mehreren Jahren Linux und Windows parallel installiert mit unterschiedlichen Linux-Distributionen und unterschiedlichen Windows-Versionen und Probleme traten bei mir eigentlich immer nur mit Windows auf, die ich dann (teilweise erst durch den Zugriff auf die Platte von Linux aus) wieder hinbekommen habe. Da ich auch hauptsächlich mit Windows arbeite und Linux nur eine "Nebenbeschäftigung" bzw. für Kleinigkeiten ist, ist die Wahrscheinlichkeit das ich mir das Linux zerschieße, geringer als es bei Windows der Fall ist...(ist bis jetzt auch noch nicht vorgekommen)^^

Allerdings hat ein frisch aufgesetztes System auch etwas für sich und man kann mal wieder Ordnung in den Datenwust bringen...

Falls es trotzdem noch eine Möglichkeit gibt, etwas dran zu machen wäre ich sehr dankbar für weitere Vorschläge oder Lösungsansätze... ;-)


Nachtrag:

Hier mal die Meldung von Windows beim Booten:

Windows failed to start. A recent hardware or software change might be the cause. To fix the Problem:

1. Insert your Windows installation Disc and restart your computer.
2. Choose your language settings, and then click "next."
3. Click "Repair your Computer."

If you do not have this disc, contact your system administrator or computer manufacturer for assistance.

     File: \Boot\BCD

     Status:  0xc000000f

     Info: An error occurred while attempting to read the boot configuration data.
« Letzte Änderung: 19. Oktober 2012, 17:19:05 von Schattenkind »

  • Windows 1.0
  • Beiträge: 7
« Antwort #3 am: 19. Oktober 2012, 17:52:20 »
2. Nachtrag

Habe gerade nocheinmal versucht mit hilfe der cmd etwas auszurichten jedoch ohne Erfolg.

Habe Bootrec.exe/rebuildbcd versucht, dabei findet er die Windowsinstallation und fragt ob sie der Startliste hinzugefügt werden soll bie antwort Ja erhalte ich die Meldung "Element nicht gefunden"

Dann habe ich /fixmbr eingegeben mit der Meldung Der Vorgang wurde abgeschlossen, jedoch startet Windows immer noch nicht... 

Leider habe ich keine weiteren Sachen dazu mehr im www gefunden... :-S

  • News-Redakteur
  • Windows XP
  • Beiträge: 5001
« Antwort #4 am: 19. Oktober 2012, 18:31:40 »
Mit EasyBCD könntest Du den Bootlader wieder herstellen. Nachdem Windows nicht mehr startet, müßtest Du allerdings mit WinPE arbeiten. Und da kenne ich mich leider gar nicht aus, vgl.:
http://de.wikipedia.org/wiki/EasyBCD#Windows_PE

Zitat
Getsern habe ich unter Windows das nervige Origin per msconfig aus dem Systemstart genommen
Was ist das "nervige Origin"? Habe ich noch nie gehört...  :grübel

  • Windows 1.0
  • Beiträge: 7
Re: Linux Mint + Windows. Nach ändern der Startoptionen startet Windows nicht mehr
« Antwort #5 am: 19. Oktober 2012, 19:43:01 »
Origin ist für Battlefield 3 quasi das, was Steam für Skyrim ist... Da man bei diesem Superteil aber schon wärend der Installation angeben muss ob es mit Windows starten soll oder nicht und diese Einstellung leider nur durch eine Neuinstallation oder eben über msconfig aus dem Autostart herauszunehmen ist, dachte ich, dass das über msconfig der einfacherere Weg wäre, da habe ich mich wohl gründlich getäuscht... :-S

Danke für den Tipp werds mal versuchen...

edit:

Eine Frage. Wäre es möglich, Windows auf eine andere Festplatte zu installieren, die benötigten Bootdatein dort zu kopieren und dann über mein Linux in den Bootordner des "alten" Windows zu kopieren? BZW. könnte das funktionieren, weil rein technisch ist es natürlich möglich...^^
« Letzte Änderung: 19. Oktober 2012, 20:47:33 von Schattenkind »

  • Windows 1.0
  • Beiträge: 7
« Antwort #6 am: 20. Oktober 2012, 17:53:32 »
So... Problem gelöst!!!

Nach einer langen Nacht mit viel hin und her und unterschiedlichsten Lösungsansätzen schreibe ich Euch gerade aus meinem alten Windows heraus :-)

Welche der Maßnahmen jetzt letzten Endes zu diesem Ergebniss geführt hat kann ich leider nicht mit Bestimmtheit sagen jedoch wollte ich Euch eben meine Ansätze posten um anderen ggf. eine Hilfestellung bieten zu können.

Folgende Maßnahmen habe ich durchgeführt:

Als erstes habe ich den Rechner gestartet und Linux laden lassen.
Von Linux aus habe ich dann die komplette Windowsplatte mit allen Daten auf eine andere Festplatte kopiert (zusätzlich noch auf eine externe Platte für den Fall das etwas in die Hose geht und alles platt gemacht werden musste).
Als nächstes habe ich alle Platten vom Rechner abgeklemmt bis auf die wo die Windowsplatte draufkopiert wurde und den Rechner mit Win-DVD im laufwerk starten lassen.
Bei der Option "Computerreparatur" wurde das "installierte" Windows auch sofort erkannt und die Routine lief durch...
Nach dem Rechnerneustart wollte Windows aber leider immer noch nicht starten, statt dessen hatte ich ich einen schwarzen Bildschirm mit der Anzeige "Grub Rescue>"
Daraufhin startete ich den Rechner erneut mit der Win-DVD und entschloß mich dazu einfach ein Win-Installation durchzuführen. (die Möglichkeit einen Systemwiederherstellungspunkt zu nutzen und die dadurch zurückgewonnenen Bootdaten dann in das ursprungswindows zu kopieren kam mir leider zu spät in den Sinn)
Nach getaner Windowsneuinstallation habe ich mir einfach die Dateien aus dem Bootordner (nur die Dateien: BCD, BCD.Backup.001, BCD.Log, BCD.Log1, BCD.Log2 und Bootstat.dat) auf einen Stick kopiert.
Anschließend habe ich die Platte abgeklemmt und nur die Platte mit Linux und Windows drauf angeklemmt und den Rechner ins Linux starten lassen. dort habe ich die kopierten Daten in den Bootordner auf der Windows-partition kopiert und einen Neustart durchgeführt.
An dieser Stelle wird es jetzt etwas seltam... :-S
Nach dem Neustart erhielt ich auch hier nur einen schwarzen Bildschirm mit "Grub Rescue>"

Da meine Linux-partition allerdings keine wichtigen Daten enthält war die Entscheidung Linux einfach neu zu installieren schnell getroffen. Also Linux neu installiert und Windowspartition mit eingebunden.
Danach wurde allerdings Windows nicht im Grub Startup als zu startendes OS zur Auswahl gestellt. Was aber mit hilfe der "Super Grub2 Disc" jetzt geändert wurde.

Die Sache mit der "Super Grub2 Disc" hätte ich sicherlich auch eher mal ausprobieren können, allerdings bin ich auf das Teil erst im Laufe der ganzen Aktion gestoßen und satand mir also vorher auch nicht zur Verfügung. Zudem hätte man an der ein oder anderen Stelle bestimmt eine einfachere oder direktere Lösung finden können, allerdings ist das ja immer so eine Sache wenn man dann einen Weg im Kopf hat und den Wald vor lauter Bäumen nicht mehr sieht... :-)

Ergebniss: Windows startet wieder, alle Daten und Einstellungen noch vorhanden und um die Erkenntniss reicher das ich beim nächsten mal direkt mit TuneUp Utilities ein Programm aus dem Autostart nehme, denn das Origin startete beim Windowsstart wieder mit und erst nach dem deaktivieren mit TuneUp hab ich meine Ruhe...^^

Die Möglichkeit das Origin gleich mit TuneUp zu deaktivieren, hatte ich bei der Aktion mit der msconfig ganz vergessen... :-S

Naja, ließt sich jetzt alles wahrscheinlich sehr wirr und durcheinander, hat aber letzten Endes doch iwie funktioniert. ;-)

@Noone: Die geschichte mit dem EasyBCD und dem WinPE war mir auf den ersten Blick doch etwas zu verwirrend und ich hätte wieder jede Menge lesen und wahrscheinlich auch dumme Fragen stellen müssen ;-) Trotzdem Danke nochmal für den Tipp :-)
« Letzte Änderung: 20. Oktober 2012, 17:57:28 von Schattenkind »

  • News-Redakteur
  • Windows XP
  • Beiträge: 5001
« Antwort #7 am: 20. Oktober 2012, 19:20:57 »
Respekt! Das zeugt wieder einmal davon, daß Doppel-H (Hirn und Hartnäckigkeit) immer noch am Besten und Schnellsten zu Ergebnissen führt.

vista windows update wiederherstellen error startet neustart weg treiber festplatte
formatieren bit installation keine installiert rechner games installieren zugreifen festplatten